This has happened more that once so I thought I’d  document the fix. “gem install nokogori” produces the following error

ERROR: Error installing nokogiri:
 ERROR: Failed to build gem native extension.

A quick check of the log file ~/.rvm/gems/ruby-1.9.3-p551/extensions/x86_64-darwin-14/1.9.1/nokogiri-1.6.8/mkmf.log shows that the package libiconv was not found.

On mac os, installing apple-gcc42 does the trick. Run brew install apple-gcc42 and try bundle install again

reference
http://stackoverflow.com/questions/19643153/error-to-install-nokogiri-on-osx-10-9-maverick